1055 The World's Richest (25 分)(排序)

1055 The World’s Richest (25 分)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​ ) - the total number of people, and K (≤10​3​​ ) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​ ,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

分析:

本题考查结构体的排序,属于简单题,常规思路是先排序再在有序序列中找出指定范围的元素。但是按照这个思路测试点1(starting from 0)运行超时,按照以往思想 以空间换时间,降低时间复杂度在这里似乎不奏效。最后参考博客1发现,结合题目输出要求,先剔除一部分不会输出的元素,降低搜索的元素个数,以达到降低程序时间复杂度。具体地为:由于给定的元素个数是N,N最大值是105,要求输出的元素个数是M,M最大值是100,两个值相差太大,我们对某一年龄段的元素进行输出最多输出100个,也就意味着这个年龄段前100个是我们关心的(若存在100个的话),超过100个的部分剔除掉,便于更好操作,我们对每一个年龄的人数进行统计,留取该年龄的前100个元素,舍弃大于100的元素,这样处理后时间复杂度会降低~~

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct node{
	string name;
	int age,net;
};
bool cmp(node a,node b){
	return a.net!=b.net?a.net>b.net:(a.age!=b.age?a.age<b.age:a.name<b.name);
}
int book[210];
int main(){
	int n,k;
	cin>>n>>k;
	vector<node> v(n),w;
	for(int i=0;i<n;i++){
		char s[10];
		int age,net;
		scanf("%s %d %d",s,&age,&net);
		v[i]=node{s,age,net};
	}
	sort(v.begin(),v.end(),cmp);
	for(int i=0;i<n;i++){
		if(book[v[i].age]<=100){
			w.push_back(v[i]);
			book[v[i].age]++;
		}
	}
	for(int i=0;i<k;i++){
		int cnt,m1,m2,tmpcnt;
		scanf("%d %d %d",&cnt,&m1,&m2);
		tmpcnt=cnt;
		printf("Case #%d:\n",i+1);
		for(auto it : w){
			if(m1<=it.age && it.age<=m2){
				printf("%s %d %d\n",it.name.c_str(),it.age,it.net);
				if(--cnt==0) break;
			}
		}
		if(cnt==tmpcnt) printf("None\n");
	}
	return 0;
}

  1. https://www.liuchuo.net/archives/2255 ↩︎

猜你喜欢

转载自blog.csdn.net/whutshiliu/article/details/82960691