1055 The World‘s Richest (25分)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10
​5
​​ ) - the total number of people, and K (≤10
​3
​​ ) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10
​6
​​ ,10
​6
​​ ]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:
For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

不难,但是挺麻烦的,还是要好好读题啊。
时间复杂度有要求,所以要用scanf和printf,但是string的scanf懂的都懂,所以在node结构体里面定义的是char[9],就可以用%s来读了,不用&。
直接对所有人进行排序,按照题目给的要求来,strcmp下一篇文章单独写。一开始我是符合年龄要求的先加入一个新数组,然后对其sort,就很麻烦。其实直接sort就行了,并记录符合年龄的人数,如果cnt==m了,就可以break了,因为只要前m个人。如果cnt == 0就输出none

#include<iostream>
#include<vector>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
    
    
    char name[9];
    int age, worth;
}nodes[100010];

bool cmp(node a, node b){
    
    
    if(a.worth != b.worth) return a.worth > b.worth;
    else if(a.age != b.age) return a.age < b.age;
    else return strcmp(a.name ,b.name )<0;
}
int main(){
    
    
    int n,k;
    cin>>n>>k;
    char name[9];
    int age, worth;
    for(int i = 0; i < n; i++){
    
    
        scanf("%s %d %d",nodes[i].name, &nodes[i].age, &nodes[i].worth);
    }
    sort(nodes,nodes+n,cmp);
    for(int i = 1; i <= k; i++){
    
    
        int m,min,max;
        int cnt= 0;
        printf("Case #%d:\n",i);
        scanf("%d%d%d",&m,&min,&max);
        for(int j = 0; j < n; j++){
    
    
            if(nodes[j].age >= min && nodes[j].age <= max){
    
    
                printf("%s %d %d\n",nodes[j].name, nodes[j].age, nodes[j].worth);
                cnt++;
            }
            if(cnt == m) break;
        }
        if(cnt == 0) cout<<"None\n";
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/J_avaSmallWhite/article/details/109252989