1055 The World's Richest (25)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=10^5^) - the total number of people, and K (<=10^3^) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-10^6^, 10^6^]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None".

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

思路:

给出n个人的姓名、年龄和拥有的钱,然后进行k次查询,每次查询输出在年龄区间内的财富值的从大到小的前m个人的信息。如果财富值相同就就先输出年龄小的,如果年龄相同就把名字按照字典序排序输出

注意会超时!

emmmm....用了算法笔记上的、柳神的代码,始终是运行超时。我仔细看了看,通过数都是0,包括1047也是。哎

C++:

#include "vector"
#include "iostream"
#include "cstdio"
#include "algorithm"
#include "cstring"
using namespace std;
struct person
{
	char name[9];
	int age;
	int worth;
};
vector<person> people;
bool cmp(person a,person b){
	if (a.worth!=b.worth)
	{
		return a.worth>b.worth;
	}else if(a.age!=b.age)
	{
		return a.age<b.age;
	}else if(a.name!=b.name){
		return (strcmp(a.name, b.name) < 0);
	}
}
int main(){
	int n,k;
	scanf("%d %d",&n,&k);
	people.resize(n);
	vector<person> v;
	vector<int> book(205,0);
	for (int i=0;i<n;i++)
		scanf("%s %d %d",people[i].name,&people[i].age,&people[i].worth);
	sort(people.begin(),people.end(),cmp);
	for (int i=0;i<n;i++)
	{
		if(book[people[i].age] < 100) {//最多查询输出只能输出100人
			v.push_back(people[i]);
			book[people[i].age]++;
		}
	}
	for (int i=0;i<k;i++)
	{
		int query,age_min,age_max;
		bool flag=false;
		vector<person> t;
		scanf("%d %d %d",&query,&age_min,&age_max);
		for (int j=0;j<v.size();j++)
		{
			if (v[j].age>=age_min&&v[j].age<=age_max)
				t.push_back(v[j]);
		}
		printf("Case #%d:\n",i+1);
		for (int j=0;j<query&&j<t.size();j++)
		{
				flag=true;
				printf("%s %d %d\n",t[j].name,t[j].age,t[j].worth);
		}
		if (!flag)
			printf("None\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ysq96/article/details/81087942