1055 The World‘s Richest (25 分)

1055 The World’s Richest (25 分)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10^5​​ ) - the total number of people, and K (≤10^​3​​ ) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10^6​​ ,10^​6​​ ]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:
For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目大意:
给定一组人的名字、年龄、财富净值,要求按照给定的maxnum、min和max,输出该年龄段内前maxnum个人的信息。如果财富净值相同,输出年龄小的;如果年龄也相同,按照名字的字典序输出

算法分析:
设置结构体数组存储每个人的信息,对结构体数组进行排序。按照给定的年龄段,输出前maxnum个人的信息

AC代码:

#include<bits/stdc++.h>
using namespace std;
struct node{
    
    
	string name;
	int age,money;
};
int cmp(node a,node b){
    
    
	if(a.money!=b.money)
	return a.money>b.money;
	if(a.age!=b.age)
	return a.age<b.age;
	return a.name<b.name;
}
int main()
{
    
    
	int nodeNum,queryNum;
	cin>>nodeNum>>queryNum;
	node peo[nodeNum];
	for(int i=0;i<nodeNum;i++){
    
    
		getchar();
		cin>>peo[i].name>>peo[i].age>>peo[i].money;
	}
	sort(peo,peo+nodeNum,cmp);//对所有人进行一次排序 
	int maxnum,min,max;
	for(int i=1;i<=queryNum;i++){
    
    
		int cnt=0,flag=0;
		scanf("%d %d %d",&maxnum,&min,&max);//按照输入的条件进行筛选,输出该年龄范围内的前maxnum个 
		printf("Case #%d:\n",i);
		for(int j=0;j<nodeNum;j++){
    
    
			if(cnt>=maxnum)//输出人数达到了maxnum,则跳出循环 
			break;
			if(peo[j].age>=min&&peo[j].age<=max){
    
    
				cout<<peo[j].name<<" "<<peo[j].age<<" "<<peo[j].money<<"\n";
				flag=1;
				cnt++;
			}
		}
		if(flag==0)
		printf("None\n");//如果没有在该年龄段内的,输出None 
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_48954087/article/details/114322459