PAT-A 1055. The World's Richest (25)(18 分)辅助指针数组

1055 The World's Richest (25)(25 分)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=10^5^) - the total number of people, and K (<=10^3^) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-10^6^, 10^6^]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None".

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

中间两个测试点没过,已经做了预处理。不知道为什么超时了。18分

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm> 
using namespace std; 
const int nmax=100010;
struct Student{
   char name[10];
   int age;
   int worths;
}stu[nmax],valid[nmax];//valid数组保存每个年龄前100人的信息 

bool cmp(Student a,Student b){
	if(a.worths!=b.worths){
		return a.worths>b.worths;//财富从大到小 
	}else{
		if(a.age!=b.age){
			return a.age<b.age;
		}
		else{//a.age==b.age
			return strcmp(a.name,b.name)<0;
		}
	} 
}
int main(int argc, char** argv) {
	int n,k;//num,query
	scanf("%d %d",&n,&k);
	getchar();
	for(int i=0;i<n;i++){
		scanf("%s %d %d",stu[i].name,&stu[i].age,&stu[i].worths);
	}
	sort(stu,stu+n,cmp);
	//预处理,以降低复杂度 
	//将每个年龄对应财富值排在前100名的都存入一个数组,
	int Age[200]={0};//Age[i]表示年龄为i的人,其财富值的排名 
	int cnt=0;//财富值的排名总数,上限是100; 
	for(int i=0;i<n;i++){
		if(Age[stu[i].age]<100){
			valid[cnt++]=stu[i];//valid[i]表示人数为cnt时,对应的人的信息 
			Age[stu[i].age]++;//该年龄的人++ 
		}
	}

	int q,ymin,ymax;
	for(int i=1;i<=k;i++){
		int printnum=0;
		scanf("%d %d %d",&q,&ymin,&ymax);
		printf("Case #%d:\n",i);
		for(int j=0;j<cnt&&printnum<q;j++){
			if(valid[j].age>=ymin&&valid[j].age<=ymax){
				printf("%s %d %d\n",valid[j].name,valid[j].age,valid[j].worths);
				printnum++;
			}
		}
		if(printnum==0){
			printf("None\n");
		}
	}
	return 0;
}
扫描二维码关注公众号,回复: 2601138 查看本文章

猜你喜欢

转载自blog.csdn.net/qian2213762498/article/details/81481486