1055 The World's Richest (25 分)PAT (Advanced Level) Practice

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of Npeople, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [AminAmax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目大意:

给出n个人的姓名、年龄和拥有的钱,然后进行k次查询

每次查询输出在年龄区间内的财富值的从大到小的前m个人的信息。

如果财富值相同就就先输出年龄小的,如果年龄相同就把名字按照字典序排序输出

题解分析:

所以先把所有的人按照财富值排序,再建立一个数组book标记每个年龄段拥有的人的数量,遍历数组并统计相应年龄的人数。

当 当前年龄的人的数量不超过100的时候压入新的数组,多出来的不要压入新数组中(因为每个年龄组不可能有的人不会太多),再从这个新的数组里面取符合相应年龄的人的信息

#include<iostream>
#include<vector>
#include<algorithm>
#include<string.h>
using namespace std;

struct node
{
	char name[10];
	int age,money;
};

int cmp(node a,node b)
{
	if(a.money!=b.money)
	   return a.money>b.money;
	else if(a.age!=b.age)
	   return a.age<b.age;
	else return strcmp(a.name,b.name)<0;//字典序升序排列        	
}

int main()
{
	int n,k,num,amin,amax;
	scanf("%d %d",&n,&k);
	
	vector<node>vt(n),v;
	vector<int>book(205,0);
	
	for(int i=0;i<n;i++)
	   scanf("%s %d %d",vt[i].name,&vt[i].age,&vt[i].money);
	sort(vt.begin(),vt.end(),cmp);
	
	for(int i=0;i<n;i++)
	{
		if(book[vt[i].age]<100)
		{//保障每个年龄的不超过100个
			v.push_back(vt[i]);
			book[vt[i].age]++;
		}	
	}
    //题目意思是总的排好序后 ,就算分着拿出来后,
    // 其子序列的排序顺序也是不变的 
    for(int i=0;i<k;i++)
    {
    	scanf("%d %d %d",&num,&amin,&amax);
    	vector<node>t;
    	for(int j=0;j<v.size();j++)
    	{
    		if(v[j].age>=amin&&v[j].age<=amax)
    		   t.push_back(v[j]);
		}
    	if(i!=0)cout<<endl;
    	printf("Case #%d:",i+1);
    	int flag=0;
    	for(int j=0;(j<num&&j<t.size());j++)
		{
			printf("\n%s %d %d", t[j].name, t[j].age, t[j].money);
            flag = 1;
		} 
    	if(flag == 0) printf("\nNone");
	}	
	return 0;
}










猜你喜欢

转载自blog.csdn.net/mlm5678/article/details/83187423