Frogger POJ - 2253 (二分搜索+图的连通性判断)

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 56014   Accepted: 17624

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

思路:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <sstream>
#include <map>

#define INF 1000000
#define eps 1e-5
using namespace std;

double G[205][205];
double GG[205][205];
int n;
int x[205],y[205];

double lowcost[205];
int vis[205];

double dijstra()
{
	memset(vis,0,sizeof(vis));
	for(int i=0;i<n;i++)
	{
		lowcost[i]=INF;
	}
	lowcost[0]=0;
	while(1)
	{
		int k=-1;
		int Min=INF;
		for(int i=0;i<n;i++)
		{
			if(lowcost[i]<Min &&vis[i]==0)
			{
				k=i;
				Min=lowcost[i];
			}
		}
		if(k==-1) break;
		vis[k]=1;
		for(int i=0;i<n;i++)
		{
			if(vis[i]==0 && lowcost[i]>lowcost[k]+G[k][i])
			{
				lowcost[i]=lowcost[k]+G[k][i];
			}
		}
	}
	return lowcost[1];
}


int main()
{
	int kase=1;
	while(scanf("%d",&n)==1)
	{
		if(n==0) break;
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&x[i],&y[i]);
		}
		getchar();
		for(int i=0;i<n;i++)
		{
			GG[i][i]=0;
			for(int j=i+1;j<n;j++)
			{
				GG[i][j]=GG[j][i]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
			}
		}
		
		double left=0,right=2000,mid;
		while(right-left>eps)
		{
			mid=(right+left)/2;
			
			for(int i=0;i<n;i++)
			{
				for(int j=0;j<n;j++)
				{
					if(GG[i][j]>=mid)
					{
						G[i][j]=INF;
					}
					else
					{
						G[i][j]=GG[i][j];
					}
				}
			}
			double ans=dijstra();
			if(fabs(ans-INF)<eps)
			{
				left=mid;
			}
			else
			{
				right=mid;
			}
		}
		
		printf("Scenario #%d\n",kase++);
		printf("Frog Distance = %.3f\n\n",mid);
		
	}
	return 0;
}

题目要求的是 最大跳跃距离的最小值  。  最大...的最小值,典型的二分算法的描述。

对于每一个路径方案,都有一个最大跳跃距离,指的是定义的这条路径上面的相邻两点的最大距离。而青蛙的跳跃距离有限,因此需要找一个最大跳跃距离的最小值。

方法:

直接二分搜索答案。直接二分这个最大距离,对每一个二分的当前值,重新构造图的邻接矩阵,让大于这个二分值的边设置为不连通(INF),然后判断当前0和1是否连通,如果连通,则说明还需要减小这个二分值,如果不连通,说明需要增大这个二分值。

扫描二维码关注公众号,回复: 1034061 查看本文章

连通的判断可以用dijstra算法,应该也可以用dfs(不确定会不会超时,应该不会)。






猜你喜欢

转载自blog.csdn.net/zl1085372438/article/details/80443262
今日推荐