Mr. Frog’s Game

One day, Mr. Frog is playing Link Game (Lian Lian Kan in Chinese). 



In this game, if you can draw at most three horizontal or vertical head-and-tail-connected lines over the empty grids(the lines can be out of the whole board) to connect two non-empty grids with the same symbol or the two non-empty grids with the same symbol are adjacent, then you can change these two grids into empty and get several more seconds to continue the game. 

Now, Mr. Frog starts a new game (that means there is no empty grid in the board). If there are no pair of grids that can be removed together,Mr. Frog will say ”I’m angry” and criticize you. 

Mr. Frog is battle-scarred and has seen many things, so he can check the board in a very short time, maybe one second. As a Hong Kong Journalist, what you should do is to check the board more quickly than him, and then you can get out of the room before Mr. Frog being angry. 
InputThe first line contains only one integer T ( T500T≤500), which indicates the number of test cases. 

For each test case, the first line contains two integers n and m ( 1n,m301≤n,m≤30). 

In the next n lines, each line contains m integers,  j-th number in the i-th line means the symbol on the grid(the same number means the same symbol on the grid). 
OutputFor each test case, there should be one line in the output. 

You should output “Case #x: y”,where x is the case number(starting from 1), and y is a string representing the answer of the question. If there are at least one pair of grids that can be removed together, the y is “Yes”(without quote), else y is “No”.Sample Input
2
3 3
1 2 1
2 1 2
1 2 1
3 3
1 2 3
2 1 2
3 2 1
Sample Output
Case #1: Yes
Case #2: No


        
  
Hint
first sample can be explained as below.

         
  


//只需判断外围每行或每列有没有相等的,内围上下左右有没有与它相等的
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
using namespace std;
int main()
{
    long long int T,i,j,o;
    scanf("%lld",&T);
    for(o=1;o<=T;o++)
    {
        long long int n,m,s=0,a[100][100];
        scanf("%lld%lld",&n,&m);
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
                scanf("%lld",&a[i][j]);
        for(j=1;j<m;j++)
            for(i=j+1;i<=m;i++)
                if(a[1][j]==a[1][i])
                    s++;
        for(j=1;j<m;j++)
            for(i=j+1;i<=m;i++)
                if(a[n][j]==a[n][i])
                    s++;
        for(j=1;j<n;j++)
            for(i=j+1;i<=n;i++)
                if(a[j][1]==a[i][1])
                    s++;
        for(j=1;j<n;j++)
            for(i=j+1;i<=n;i++)
                if(a[j][m]==a[i][m])
                    s++;
        if(s>0)
            printf("Case #%d: Yes\n",o);
        else
        {
            for(i=1;i<n;i++)
                for(j=1;j<m;j++)
                    if(a[i][j]==a[i][j+1]||a[i][j]==a[i+1][j])
                        s++;
            if(s>0)
                printf("Case #%d: Yes\n",o);
            else
                printf("Case #%d: No\n",o);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zcy19990813/article/details/80147840