英文单词排序(c语言版)

本题要求编写程序,输入若干英文单词,对这些单词按长度从小到大排序后输出。如果长度相同,按照输入的顺序不变。

输入格式:
输入为若干英文单词,每行一个,以#作为输入结束标志。其中英文单词总数不超过20个,英文单词为长度小于10的仅由小写英文字母组成的字符串。

输出格式:
输出为排序后的结果,每个单词后面都额外输出一个空格。

输入样例:
blue
red
yellow
green
purple

输出样例:
red blue green yellow purple

#include <stdio.h>
#include <string.h>

void sort_length(char (*p)[11], int n);    //使用数组指针指向二维数组 

int main()
{
    char word[21][11];						//不超过20, 不超过10,  要多开一个存放结束符 
    char str[11];
    int i, j, n;

    i = 0; n  = 0;
    while (1)
    {
        scanf("%s", str);
        if (str[0] == '#')						//不能写成str == '#'   str是字符串的首地址 
            break;
        strcpy(word[i], str);
        i++;
        n++;								//n记录字符串的个数 
    }
    sort_length(word, n);

    return 0;
}
void sort_length(char (*p)[11], int n)
{
    int i, j;
    char temp[11];

    for (i = 0; i < n - 1; i++)
    {
        for (j = 0; j < n - 1 - i; j++)
        {
            if (strlen(p[j]) > strlen(p[j + 1]))
            {
                strcpy(temp, p[j]);
                strcpy(p[j], p[j + 1]);
                strcpy(p[j + 1], temp);
            }
        }
    }
    for (i = 0; i < n; i++)
        printf("%s ", p[i]);
}
发布了24 篇原创文章 · 获赞 0 · 访问量 153

猜你喜欢

转载自blog.csdn.net/qq_45624989/article/details/105086764