HDU -> ACM -> FatMouse's Speed

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.Two mice may have the same weight, the same speed, or even the same weight and speed.
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that W[m[1]] < W[m[2]] < ... < W[m[n]]and S[m[1]] > S[m[2]] > ... > S[m[n]]In order for the answer to be correct, n should be as large as possible.All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 

Sample Input
 
  
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
 

Sample Output
 
  



4
4
5
9
7
#include<iostream>
#include<algorithm>
#include<stdio.h>

using namespace std;

int l[1001];
int flag[1001][1001];//当把两个数组放到这里时不会出现栈溢出
struct Mice
{
    int w;
    int s;
    int id;
};
Mice mices[1001];
int cmp(struct Mice a,struct Mice b)
{
    if(a.w!=b.w) return a.w<b.w;
    else return a.s>b.s;
}
int main()
{
    //int l[1001];//存储最大递减序列的长度的值
    //int flag[1001][1001];//存储递减序列下表的值
    int i,size,j,k,max,t;
    i=0;
    while(scanf("%d %d",&mices[i].w,&mices[i].s)!=EOF)
    {
        mices[i].id=i+1;
        i++;
    }
    size=i;
    sort(mices,mices+size,cmp);
    for(i=0;i<size;i++)
    {
        l[i]=1;
        flag[i][0]=i;
    }
    for(i=1;i<size;i++)
    {
        for(j=i-1;j>=0;j--)
        {
            if(mices[i].w>mices[j].w && mices[i].s<mices[j].s && l[i]<l[j]+1)
            {
                max=l[j]+1;
                l[i]=max;

            for(k=0;k<max-1;k++)
                flag[i][k]=flag[j][k];
            flag[i][max-1]=i;
            }
        }
    }
    int index;
        for(index=0,k=1;k<size;k++)
         if(l[index]<l[k]) index=k;

    cout<<l[index];

    for(i=0;i<l[index];i++)
        cout<<endl<<mices[flag[index][i]].id;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/desporado/article/details/80173369
今日推荐