3752走迷宫(bfs)

题目描述
一个迷宫由R行C列格子组成,有的格子里有障碍物,不能走;有的格子是空地,可以走。
给定一个迷宫,求从左上角走到右下角最少需要走多少步(数据保证一定能走到)。只能在水平方向或垂直方向走,不能斜着走。

Input
第一行是两个整数,R和C,代表迷宫的长和宽。( 1<= R,C <= 40)
接下来是R行,每行C个字符,代表整个迷宫。
空地格子用’.’表示,有障碍物的格子用’#’表示。
迷宫左上角和右下角都是’.’。
Output
输出从左上角走到右下角至少要经过多少步(即至少要经过多少个空地格子)。计算步数要包括起点和终点。
Sample Input

5 5
…###
#…
#.#.#
#.#.#
#.#…

Sample Output
9

#include<iostream>
#include<queue>
using namespace std;
char aa[100][100];
int dir[4][2]={-1,0,1,0,0,-1,0,1};
int vis[100][100]={0};
int m,n;

typedef struct NODE{
	int x;
	int y;
	int step;
}node;

int bfs(int a,int b){
	node temp,next;
	temp.x=a;
	temp.y=b;
	temp.step=1;
	vis[temp.x][temp.y]=1;
	queue<node> q;
	q.push(temp);
	while(!q.empty()){	
		temp=q.front();
		q.pop();
		for(int i=0;i<4;i++){
			next.x=temp.x+dir[i][0];
			next.y=temp.y+dir[i][1];
			next.step=temp.step+1;
			if(next.x<0 || next.y<0 ||next.x>m || next.y>n ||vis[next.x][next.y]==1 ||aa[next.x][next.y]=='#'){
				continue;
			}
			if(next.x==m-1 &&next.y==n-1){
				return next.step;
			}
			vis[next.x][next.y]=1;
			q.push(next);
		}
		
	}
}



int main(){

	cin>>m>>n;
	
	for(int i=0;i<m;i++){
		for(int j=0;j<n;j++){
			cin>>aa[i][j];
		}
	}	
	int ans=bfs(0,0);
	cout<<ans;
	
	
	return 0;
}

ask
?能否用 dsf解决?

发布了27 篇原创文章 · 获赞 1 · 访问量 1673

猜你喜欢

转载自blog.csdn.net/qq_37959151/article/details/89762813