PAT A1061 Block Reversing (25分)

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.
Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:

71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1
  • 思路:
    链表模板题,将最终结果存入ans,遍历ans输出
    用一个二维数组tmp,每k个节点组成一个临时vector:tmp2,并将其push进tmp

  • code:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 100010;

struct Node
{
    int data, nex;
}node[maxn];


void Print(const vector<int> & ans)
{
    if(ans.size() == 0)
    {
        printf("0 -1");
    }else
    {
        for(int i = 0; i < ans.size(); ++i)
        {
            if(i < ans.size() - 1) printf("%05d %d %05d\n", ans[i], node[ans[i]].data, ans[i+1]);
            else printf("%05d %d -1\n", ans[i], node[ans[i]].data);
        }
    }
}

int main()
{
    int first, n, k;
    scanf("%d %d %d", &first, &n, &k);
    for(int i = 0; i < n; ++i)
    {
        int ad;
        scanf("%d", &ad);
        scanf("%d %d", &node[ad].data, &node[ad].nex);
    }
    int head = first, cnt = 1;
    vector<vector<int> > tmp;
    vector<int> tmp2, ans;
    while(head != -1)
    {
        tmp2.push_back(head);
        if(cnt % k == 0 || node[head].nex == -1)
        {
            tmp.push_back(tmp2);
            tmp2.clear();
        }
        cnt++;
        head = node[head].nex;
    }
    for(int i = tmp.size()-1; i >= 0; --i)
    {
        for(int j = 0; j < tmp[i].size(); ++j)
        {
            ans.push_back(tmp[i][j]);
        }
    }
    Print(ans);
    return 0;
}

发布了316 篇原创文章 · 获赞 5 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_42347617/article/details/105471805