18年冬季第四题 PAT甲级 1155 Heap Paths (30分)

汇总贴

2020年3月PAT甲级满分必备刷题技巧

题目

题目来源:https://pintia.cn/problem-sets/994805342720868352/problems/1071785408849047552

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题目分析

1.level order traversal sequence of a complete binary tree
因为输入是层序的完全二叉树,直接存数组里,用DFS就能遍历从根到叶了。

2.all the paths in its right subtree must be printed before those in its left subtree
先打印右子树,再打印左子树。这个在DFS函数里写好就行。

3. liuchuo的DFS函数跟我的有点不同,稍微复杂些,也可以看看:https://blog.csdn.net/liuchuo/article/details/84973009

满分代码

#include<iostream>
#include<vector>
using namespace std;
const int maxn=1005;
vector<int> v(maxn);
vector<int> vf;
int n;
void f(int s){//打印经过第s节点的所有路径
    if(s>n){
        for(int i=0;i<vf.size();i++){
            if(i!=0)printf(" ");
            printf("%d",vf[i]);
        }
        printf("\n");
        return;
    }
    vf.push_back(v[s]);
    if(s*2+1<=n)f(s*2+1);//如果s有右孩子,就去打印经过右孩子的路径
    f(s*2);//如果s有左孩子,同上,如果没有,就直接打印以s为终点的路径
    vf.pop_back();
}
int main(){
    int minheap=1,maxheap=1;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&v[i]);
        if(i>1 && v[i/2]<v[i])maxheap=0;
        if(i>1 && v[i/2]>v[i])minheap=0;
    }
    f(1);
    if(minheap==1)printf("Min Heap\n");
    else printf("%s\n",maxheap==1?"Max Heap":"Not Heap");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/allisonshing/article/details/104448296
今日推荐