PAT甲级1155 Heap Paths (30分)|C++实现

一、题目描述

原题链接
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

​​Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

二、解题思路

完全二叉树的dfs以及判断,我们依然可以使用两个全局变量isMax,isMin表示是最大堆,是最小堆,因为我们知道每次dfs到叶子结点的时候,形成的路径一定是单调的,所以直接比较最后两个元素即可。详情见代码注释。

三、AC代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int all[1010], N, isMax = 1, isMin = 1;
vector<int> path;
void dfs(int root)  //dfs
{
    
    
    if(root*2+1 >= N)
    {
    
    
        for(int i=0; i<path.size(); i++)
        {
    
    
            printf("%d%s", path[i], i != path.size()-1 ? " " : "\n");
            if(i>0 && path[i] > path[i-1])  isMax = 0;  //下一层的数字更大,则不是最大堆
            if(i>0 && path[i] < path[i-1])  isMin = 0;  //下一层的数组更小,则不是最小堆
        }
            
    }
    else
    {
    
    
        if(root*2 + 2 < N)  //如果还有右孩子,继续往下遍历
        {
    
    
            path.push_back(all[root * 2 + 2]);
            dfs(root*2 + 2);
            path.pop_back();
        }
        path.push_back(all[root*2 + 1]);
        dfs(root*2 + 1);
        path.pop_back();    //注意这里一定要pop_back
    }
}
int main()
{
    
    
    scanf("%d", &N);
    for(int i=0; i<N; i++)
        scanf("%d", &all[i]);
    path.push_back(all[0]); //先将根结点push进path中
    dfs(0);
    if(isMin == 1)  printf("Min Heap");
    else    isMax == 1 ? printf("Max Heap") : printf("Not Heap");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42393947/article/details/109126770
今日推荐