poj3253--pat---优先队列---堆

Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 36332   Accepted: 11772

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
******************************************************************************************************************

******************************************************************************************************************

农夫要修理牧场的一段栅栏,他测量了栅栏,发现需要NNN块木头,每块木头长度为整数LiL_iLi个长度单位,于是他购买了一条很长的、能锯成NNN块的木头,即该木头的长度是LiL_iLi的总和。

但是农夫自己没有锯子,请人锯木的酬金跟这段木头的长度成正比。为简单起见,不妨就设酬金等于所锯木头的长度。例如,要将长度为20的木头锯成长度为8、7和5的三段,第一次锯木头花费20,将木头锯成12和8;第二次锯木头花费12,将长度为12的木头锯成7和5,总花费为32。如果第一次将木头锯成15和5,则第二次锯木头花费15,总花费为35(大于32)。

请编写程序帮助农夫计算将木头锯成NNN块的最少花费。

输入格式:

输入首先给出正整数NNN≤104\le 10^4104),表示要将木头锯成NNN块。第二行给出NNN个正整数(≤50\le 5050),表示每段木块的长度。

输出格式:

输出一个整数,即将木头锯成NNN块的最少花费。

输入样例:

8
4 5 1 2 1 3 1 1

输出样例:

49


pat和poj的同一个题,大体题意是:农夫需要锯木头,锯多长就要花多少钱,需要n块木头,问花费的最小钱数。
思路:   经典哈夫曼思想:先排序,然后每次找出其中2个费用最小的木头加起来,把和放进原来的序列里,知道剩下最后一个元素。
但是,如果每次都排一次序一定会超时的!这里我们可以用优先队列或者堆维护,这样的话复杂度将会大大降低。
poj的数据量比pat大,所以虽然一开始在pat过了,但在poj该死过不去,后来才发现,将答案改成了long long 终于过了。


///*   利用STL中的堆 维护
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <list>
#include <algorithm>
#include <cmath>
#include <string>
#include <queue>
using namespace std;
int a[30010];
bool cmp(const int a,const int b){
	return a > b;
}
int main(int argc, char *argv[]) {
	int n;
	long long ans = 0;
	cin>>n;
	for(int i = 1; i <= n; ++i) cin>>a[i];
	make_heap(a+1,a+1+n,cmp);
	while(n != 1){
		pop_heap(a+1,a+1+n,cmp);
		int t1 = a[n];
		n--;
		pop_heap(a+1,a+1+n,cmp);
		int t2 = a[n];
		int sum = t1 + t2;
		ans += sum;
		a[n] = sum;
		push_heap(a+1,a+1+n,cmp);
	}
	cout<<ans<<endl;
	return 0;
}
//*/
///******************************************************************************************
///  利用STL 中的优先队列维护
///******************************************************************************************
/*
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <list>
#include <algorithm>
#include <cmath>
#include <string>
#include <queue>
using namespace std;
int main(int argc, char *argv[]) {
	
	int n;
	long long ans = 0;
	while(cin>>n){
	ans = 0;
    priority_queue<int,vector<int>,greater<int> > q;
	int t = n;
	while(t--){
		int tmp;
		cin>>tmp;
		q.push(tmp);
	}
	while(q.size() != 1){
		int t1 = q.top();
		q.pop();
		int t2 = q.top();
		q.pop();
		int sum = t1 + t2;
		ans += sum;
		q.push(sum);
	}
	cout<<ans<<endl;
    }
	return 0;
}
*/



猜你喜欢

转载自blog.csdn.net/shengsikandan/article/details/50900255