poj 2559 Largest Rectangle in a Histogram(单调栈)

Largest Rectangle in a Histogram
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18691   Accepted: 6005

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer  n, denoting the number of rectangles it is composed of. You may assume that  1<=n<=100000. Then follow  n integers  h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is  1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8

4000

solotion:

给你高度为a[i],宽度为1的矩形,问你形成的最大的矩形面积是多少,建立一个单调递增栈,所有元素各进栈和出栈一次即可。每个元素出栈的时候更新最大的矩形面积。

#include<cstdio>
#include<algorithm>
#include<stack>
using namespace std;
struct node{
	int w, h;
}a,b;
int main()
{
	int n;
	while (scanf("%d", &n) && n)
	{
		stack<node>q;
		long long ans = 0;
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &a.h);
			a.w = 1;
			if (q.empty() || q.top().h < a.h)
			{
				q.push(a); continue;
			}
			int sum = 0;
			while (!q.empty() && q.top().h >= a.h)
			{
				ans = max(ans, 1ll*q.top().h*(q.top().w+sum));
				sum += q.top().w;
				q.pop();
			}
			a.w+= sum;
			q.push(a);
		}
		int sum = 0;
		while (!q.empty())
		{
			ans = max(ans, 1ll * q.top().h*(q.top().w+sum));
			sum += q.top().w;
			q.pop();
		}
		printf("%lld\n", ans);
	}
	retu


猜你喜欢

转载自blog.csdn.net/qq_22522375/article/details/51524739
今日推荐