POJ - 2559 Largest Rectangle in a Histogram (单调栈)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/89398912

Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

题目大意:有n个宽度为1的矩形,给出每个的高度,求出能构成的矩形的最大面积

思路:可以转变成求区间最小值乘以区间长度的最大值,以i 为区间最小值,向两边延伸,求出区间的长度

利用单调栈找到右边第一个小于i的矩形的位置,减一就是区间向右延伸的最远的地方,同理求得左边的,就能得到区间的长度

代码:

#include<stdio.h>
#include<string.h>
#include<stack>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
const int N=100005;
int a[N],l[N],r[N],s[N];
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        a[n+1]=-1,a[0]=-1;
        int top=0; //清空栈
        for(int i=1; i<=n+1; i++)
        {
            if(top==0||a[s[top]]<=a[i]) //如果栈为空,或者栈顶元素小于等于a[i]
                s[++top]=i;
            else
            {
                while(top&&a[s[top]]>a[i])//如果a[i]小于栈顶元素,维护栈的单调性,出栈
                {
                    r[s[top]]=i-1; 
                    --top;
                }
                s[++top]=i;
            }
        }
        top=0;
        for(int i=n; i>=0; i--)
        {
           if(top==0||a[s[top]]<=a[i])
                s[++top]=i;
            else
            {
                while(top&&a[s[top]]>a[i])
                {
                    l[s[top]]=i+1;
                    --top;
                }
                s[++top]=i;
            }
        }
        ll maxx=-1;
        for(int i=1; i<=n; i++)
        {
//                printf("%d %d\n",l[i],r[i]);
            maxx=max(maxx,(ll)a[i]*(r[i]-l[i]+1));
        }
        printf("%lld\n",maxx);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/89398912
今日推荐