HDU 1702 ACboy needs your help again!(栈和队列)

题目

Problem Description

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor ? ? ? ?
As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    
    
    int N,M,num;
    string str1,str2;
    cin>>N;
    while (N)
    {
    
    
        str1.clear();
        str2.clear();
        cin>>M>>str1;
        if (str1=="FILO")  //栈
        {
    
    
            stack <int> s;
            while (M)
            {
    
    
                cin>>str2;
                if (str2=="IN")
                {
    
    
                    cin>>num;
                    s.push(num);
                }
                else if(str2=="OUT")
                {
    
    
                    if (!s.empty())
                    {
    
    
                        cout<<s.top()<<endl;
                        s.pop();
                    }
                    else
                        cout<<"None"<<endl;
                }
                M--;
            }
        }
        else if (str1=="FIFO")  //队列
        {
    
    
            queue <int> q;
            while (M)
            {
    
    
                cin>>str2;
                if (str2=="IN")
                {
    
    
                    cin>>num;
                    q.push(num);
                }
                else if(str2=="OUT")
                {
    
    
                    if (!q.empty())
                    {
    
    
                        cout<<q.front()<<endl;
                        q.pop();
                    }
                    else
                        cout<<"None"<<endl;
                }
                M--;
            }
        }
        N--;
    }
    return 0;
}

理解

FIFO是谁先输入谁先输出,FILO是谁先输入谁后输出。
即FIFO用队列,FILO用,可以很快解决这个题目。
需要注意的是,队列和栈的很多函数是相同的,但也有一定的差异,要注意区分。

猜你喜欢

转载自blog.csdn.net/weixin_44918971/article/details/95624642
今日推荐