HDU 1702 ACboy needs your help again!

ACboy needs your help again!

**Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11902    Accepted Submission(s): 5949**

Problem Description

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

Source

2007省赛集训队练习赛(1)

Recommend

lcy   |   We have carefully selected several similar problems for you:  1701 1700 1703 1704 1706

题解

按照题目进行模拟。
代码如下:

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <stack>
#include <queue>
#define ll long long

using namespace std ;

int main(){
    int t ;
    cin >> t ;
    while (t --){
        int n ;
        string str ;
        cin >> n >> str ;
        stack<int> sta_ ;
        queue<int> que_ ;
        while (n --){
            int k ;
            string str1 ;
            cin >> str1 ;
            if (str == "FIFO"){
                if (str1 == "IN"){
                    cin >> k ;
                    que_.push(k) ;
                }else{
                    if (que_.size() == 0){
                        cout << "None" << endl ;
                    }else{
                        cout << que_.front() << endl ;
                        que_.pop() ;
                    }
                }
            }else{
                if (str1 == "IN"){
                    int k ;
                    cin >> k ;
                    sta_.push(k) ;
                }else{
                    if (sta_.size() == 0){
                        cout << "None" << endl ;
                    }else{
                        cout << sta_.top() << endl ;
                        sta_.pop() ;
                    }
                }
            }
        }
    }
    return 0 ;
}

猜你喜欢

转载自www.cnblogs.com/Cantredo/p/10013662.html