【kmp】poj 2752 Seek the Name, Seek the Fame

Seek the Name, Seek the Fame

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 31173   Accepted: 16208

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

next数组的应用——前缀后缀相同位置

从len位置往前跳到-1

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
const int maxn=4e5+5;
char c[maxn];
int p[maxn];
void next()
{
	p[0]=-1;
	int i=0,j=-1;
	int len=strlen(c);
	while(i<len)
	{
		if(j==-1 || c[i]==c[j]) i++,j++,p[i]=j;
		else j=p[j];
	}
}
int ans[maxn],cnt;
int main()
{
	freopen("a.in","r",stdin);
	freopen("a.out","w",stdout);
	while(scanf("%s",c)!=EOF)
	{
		memset(p,0,sizeof(p));
		int len=strlen(c);
		next(); cnt=0;
		int pos=len;
		while(p[pos]!=-1)
		{
			ans[++cnt]=pos;
			pos=p[pos];
		}
		for(int i=cnt;i>=1;i--) printf("%d ",ans[i]);
		printf("\n");
	}
	return 0;	
} 

猜你喜欢

转载自blog.csdn.net/andyc_03/article/details/110059405
今日推荐