PAT (Advanced Level) Practice 1028 List Sorting (25 分)

题目

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤ 1 0 5 10^{5} 105​​ ) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

代码

#include<iostream>
#include<algorithm>
using namespace std;
struct s{
    
    
	string id;
	string name;
	int score;
};
bool cmp1(s s1,s s2)
{
    
    
	return s1.id < s2.id;
}
bool cmp2(s s1,s s2)
{
    
    
	return s1.name == s2.name ?  s1.id < s2.id : s1.name < s2.name;
}
bool cmp3(s s1,s s2)
{
    
    
	return s1.score == s2.score ?  s1.id < s2.id : s1.score < s2.score;
}
int main()
{
    
    
	int n,c;
	cin >> n >> c;
	struct s stu[n];
	for(int i = 0;i < n;i++)
		cin >> stu[i].id >> stu[i].name >> stu[i].score;
	if(c == 1)
		sort(stu,stu+n,cmp1);
	else if(c == 2)
		sort(stu,stu+n,cmp2);
	else if(c == 3)
		sort(stu,stu+n,cmp3);
	for(int i = 0;i < n;i++)
		cout << stu[i].id << " " << stu[i].name << " " << stu[i].score << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43820008/article/details/114002855