4.5 PAT A1048 Find Coins (25分)(二分)

1048 Find Coins (25分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

将给定值排序后从两头i,j枚举,和大于给定值j前移,等于输出,小于i后移 。

参考代码:

#include <cstdio>
#include <algorithm>
using namespace std;
int val[100010];
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(int i=0;i<n;++i)
			scanf("%d",&val[i]);
		sort(val,val+n); //将面值从小到大排序
		bool flag=false; //记录是否存在解 
		int i=0,j=n-1;
		while(i<j)
		{
			if(val[i]+val[j]==m)
			{
				flag=true;
				printf("%d %d\n",val[i],val[j]);
				break;
			}
			else if(val[i]+val[j]>m)
				--j;
			else
				++i;
		}
		if(!flag)
			printf("No Solution\n");
	}
	return 0;
}

参考代码2:

#include <cstdio>
#include <algorithm>
using namespace std; 
int a[100010];
int bin(int l,int r,int x)
{
	int mid;
	while(l<=r)
	{
		mid=(l+r)/2;
		if(a[mid]==x)
			return mid;
		else if(a[mid]>x)
			r=mid-1;
		else
			l=mid+1;
	}
	return -1;
}
int main()
{
	int i,n,m;
	scanf("%d%d",&n,&m);
	for(i=0;i<n;++i)
		scanf("%d",&a[i]);
	sort(a,a+n);
	bool flag=true;
	for(i=0;i<n;++i)
	{
		int ans=bin(i,n-1,m-a[i]); //二分查找右端点
		if(ans!=-1&&ans!=i)
		{
			printf("%d %d\n",a[i],a[ans]);
			flag=false;
			break;
		}	
	}
	if(flag)
		printf("No Solution\n");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43590614/article/details/105029065
今日推荐