Roadblocks(次短路)

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers: N and R
Lines 2…R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450
Hint
Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
译文:
在一个乡村有N个农场(编号1到N),R 条双向边
现在Bessie想从家(1号农场)走到朋友(N号农场)那里去,但是他不想走得太快,所以他决定走用时第二长的路。

[Input]

第一行两个整数N和R

接下来R行每行三个整数A B D,表示A和B有一条用时为D的双向边

[Output]

一行一个整数,即Bessie所走的路的用时

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
struct edge
{
    
    
	int v,w,next;
} e[200005];
int n,m;
int head[5050];
int k;
int s,t;
int dis[5050][2];
bool vis[5050][2];
void adde(int u,int v,int w)
{
    
    
	e[k].v=v;
	e[k].w=w;
	e[k].next=head[u];
	head[u]=k++;
}
int djk(int s,int t)
{
    
    
	memset(dis,0,sizeof(dis));
	memset(vis,0,sizeof(vis));
	for(int i=1; i<=n; i++)
	{
    
    
		dis[i][0]=inf;
		dis[i][1]=inf;
	}
	dis[s][0]=0;
	for(int i=1; i<=2*n; i++)
	{
    
    
		int temp=inf,mark,flag;
		for(int j=1; j<=n; j++)
		{
    
    
			if(!vis[j][0]&&dis[j][0]<temp)
			{
    
    
				temp=dis[j][0];
				mark=j;
				flag=0;
			}
			else if(!vis[j][1]&&dis[j][1]<temp)
			{
    
    
				temp=dis[j][1];
				mark=j;
				flag=1;
			}
		}
		vis[mark][flag]=1;
		for(int j=head[mark]; j!=-1; j=e[j].next)
		{
    
    
			int  v=e[j].v;
			if(temp+e[j].w<dis[v][0])
			{
    
    
				dis[v][1]=dis[v][0];
				dis[v][0]=temp+e[j].w;
			}
			else if(temp+e[j].w<dis[v][1])
			{
    
    
				dis[v][1]=temp+e[j].w;
			}
		}
	}
	return dis[t][1];
}
int main()
{
    
    
	scanf("%d%d",&n,&m);
	for(int i=1; i<=n; i++)
	head[i]=-1;
	k=0;
	for(int i=1; i<=m; i++)
	{
    
    
		int u,v,c;
		scanf("%d%d%d",&u,&v,&c);
		adde(u,v,c);
		adde(v,u,c);
	}
	printf("%d\n",djk(1,n));
	return 0;
}```

猜你喜欢

转载自blog.csdn.net/zlzqq/article/details/113189616