期望dp

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

在这里插入图片描述

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

Sample Input

2 2
0.00 0.50 0.50    0.50 0.00 0.50
0.50 0.50 0.00    1.00 0.00 0.00

Sample Output

6.000

题意:有一个R*C的网格,每走一次消耗2点能量,现在要从起点 (1,1) 走到 (R , C),有三种走法:第一种原点不动;第二种向下走;第三种:向右走。三种走法的概率之和为1。求走到出口需要能量值的期望值。

原点的概率,往右走一步的概率,往下走一步的概率分别用p1,p2,p3表示,
则期望等于dp[i][j]=dp[i][j]*p1+dp[i][j+1]*p2+dp[i+1][j]*p3+2(2为移动一次的消耗的能量)化简为
dp[i][j]=(dp[i][j+1]*p2+dp[i+1][j]*p3+2)/(1-p1);
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=1050;
double mp[maxn][maxn][3];
double dp[maxn][maxn];
int main()
{
    
    
	int r,c;
	while(cin>>r>>c)
	{
    
    
		if(r+c==0) break;
		for(int i=1; i<=r; i++)
			for(int j=1; j<=c; j++)
				for(int k=0; k<3; k++)
					scanf("%lf",&mp[i][j][k]);
		memset(dp,0,sizeof(dp));
		for(int i=r; i>=1; i--)
		{
    
    
			for(int j=c; j>=1; j--)
			{
    
    
				if(i==r&&j==c) continue;
				double a=1.0*mp[i][j][0];//不动的概率
				double b=1.0*dp[i][j+1]*mp[i][j][1];///往右走一步的期望
				double c=1.0*dp[i+1][j]*mp[i][j][2];///往下走一步的期望
				if(1-a<1e-7) continue;//一直在原点
				dp[i][j]=(b+c+2.0)/(1.0-a);//期望值
			}
		}
		printf("%.3lf\n",dp[1][1]);
	}
}

猜你喜欢

转载自blog.csdn.net/csx_zzh/article/details/115259983