POJ - 3041 Asteroids(最小点覆盖)

                                                Asteroids

Time Limit: 1000MS   Memory Limit: 65536K

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X. 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

题意: 在n*n的地图上有k个障碍物,每次开炮可以清除一行或一列的障碍物,问消除全部障碍物需要开几炮. (二营长你会么?)

解题思路:最小点覆盖,可以转化成二分图最大匹配然后用匈牙利算法。这题只需将行号和列号分别转化为而二分图的一侧,(i,j)即 i和 j 可连接 。    原因: 一个行号/列号 只能匹配一次,保证一行/一列不会重复开炮。

ACCode:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
bool e[510][510],vis[510];
int match[510],n;
bool xyl(int x)
{
	for(int i=1;i<=n;i++) {
		if(e[x][i] && !vis[i]) {
			vis[i] = true;
			if(match[i] == -1 || xyl(match[i])) {
				match[i] = x;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	int k,r,c;
	while(~scanf("%d%d",&n,&k)) {
		memset(e,false,sizeof e);
		memset(match,-1,sizeof match);
		for(int i=1;i<=k;i++) {
			scanf("%d%d",&r,&c);
			e[r][c] = true; 
		}
		int tot = 0;
		for(int i=1;i<=n;i++) {
			memset(vis,false,sizeof vis);
			if(xyl(i)) tot++;
		}
		printf("%d\n",tot);	
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_42765557/article/details/98482027