POJ - 3041 Asteroids 【最小点覆盖】

Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 25309   Accepted: 13659

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source


思路:

点覆盖,在图论中点覆盖的概念定义如下:对于图G=(V,E)中的一个点覆盖是一个集合S⊆V使得每一条边至少有一个端点在S中。

最小点覆盖=最大匹配数

关于匹配的一些概念:https://blog.csdn.net/flynn_curry/article/details/52966283

这里的点表示x、y的坐标。最小点覆盖就是取最少的边,能够覆盖所有的点。

一个点表示为(x,y)的一条边,直接跑匈牙利算法。

类似题:魔理沙又来偷书了

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define MAXN 510
int k,n,m;
int match[MAXN];
bool used[MAXN];
char G[MAXN][MAXN];
vector<int> vec[MAXN];
bool find(int u)
{
    for(int i=0;i<vec[u].size();i++)
    {
        int v=vec[u][i];
        if(!used[v])
        {
            used[v]=1;
            if(match[v]==-1 || find(match[v]))
            {
                match[v]=u;
                return true;
            }
        }
    }
    return false;
}
int hungry()
{
    int ans=0;
    memset(match,-1,sizeof match);
    for(int i=1;i<=n;i++)
    {
        memset(used,0,sizeof used);
        if(find(i)) ans++;
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<=n;i++)
            vec[i].clear();
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            vec[u].push_back(v);
        }
        printf("%d\n",hungry());
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/u013852115/article/details/80351921