#1097. Deduplication on a Linked List【链表】

原题链接

Problem Description:

Given a singly linked list L L L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K K K, only the first node of which the value or absolute value of its key equals K K K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L L L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N N N ( ≤ 1 0 5 \leq10^5 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N N N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 1 0 4 10^4 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

Problem Analysis:

开两个数组分别存储保留的节点和删除的节点,将出现过的 key 用布尔数组标记。详细细节见代码。

Code

#include <iostream>
#include <cstring>
#include <vector>

using namespace std;

const int N = 100010;

int n;
int h, e[N], ne[N];
bool st[N];

int main()
{
    
    
    scanf("%d%d", &h, &n);
    for (int i = 0; i < n; i ++ )
    {
    
    
        int address, key, next;
        scanf("%d%d%d", &address, &key, &next);
        e[address] = key, ne[address] = next;
    }

    vector<int> a, b;
    for (int i = h; ~i; i = ne[i])
    {
    
    
        int v = abs(e[i]);
        if (st[v]) b.push_back(i);
        else 
        {
    
    
            st[v] = true;
            a.push_back(i);
        }
    }

    for (int i = 0; i < a.size(); i ++ )
    {
    
    
        printf("%05d %d ", a[i], e[a[i]]);
        if (i == a.size() - 1) puts("-1");
        else printf("%05d\n", a[i + 1]);
    }

    for (int i = 0; i < b.size(); i ++ )
    {
    
    
        printf("%05d %d ", b[i], e[b[i]]);
        if (i == b.size() - 1) puts("-1");
        else printf("%05d\n", b[i + 1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121118746