1097. Deduplication on a Linked List (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zs391077005/article/details/79114658


时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

提交代码

扫描二维码关注公众号,回复: 4326328 查看本文章
#include<fstream>
#include <cstdio>
#include <iostream>
#include<algorithm>
#include<set>
#include<map>
#include<vector>
#include<string>
#include<cmath>
#include<stack>
using namespace std;
const int maxn=100000;
struct NODE{
	int address,key,next,num;
}node[maxn];
bool exist[maxn];
bool cmp(NODE a,NODE b)
{return a.num<b.num;}
int main()
{
	int start,n;
	scanf("%d %d",&start,&n);
	for(int i=0;i<maxn;i++)
		node[i].num=maxn*2;
	for(int i=0;i<n;i++)
	{
		int tempid,key,next;
		scanf("%d %d %d",&tempid,&key,&next);
		node[tempid].address=tempid;
		node[tempid].key=key;
		node[tempid].next=next;
	}
	int cnt1=0,cnt2=0;
	for(int i=start;i!=-1;i=node[i].next)
	{
		if(exist[abs(node[i].key)]==false)
		{
			exist[abs(node[i].key)]=true;
			node[i].num=cnt1++;
		}
		else 
		{
			node[i].num=cnt2+maxn;
			cnt2++;
		}
	}
	sort(node,node+maxn,cmp);
	int cnt=cnt1+cnt2;
	for(int i=0;i<cnt;i++)
	{
		if(i!=cnt1-1&&i!=cnt-1)
			printf("%05d %d %05d\n",node[i].address,node[i].key,node[i+1].address);
		else 
			printf("%05d %d -1\n",node[i].address,node[i].key);
	}
#ifdef _DEBUG
	system("pause");
#endif	


	return 0;
	
}


猜你喜欢

转载自blog.csdn.net/zs391077005/article/details/79114658