#1032. Sharing【链表】

原题链接

Problem Description:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

在这里插入图片描述
Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N N N ( ≤ 1 0 5 \leq 10^5 105), where the two addresses are the addresses of the first nodes of the two words, and N N N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by − 1 −1 1.

Then N N N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

Problem Analysis:

题目要求找到两个单链表的第一个公共节点,与 AcWing 66. 两个链表的第一个公共结点 类似。

直接遍历第一个链表,将出现过的节点全部标记,然后再遍历第二个节点,找到第一个被标记过的点,就是二者的第一个公共节点。

Code

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 100010;

int n;
int h1, h2, ne[N]; // 两个链表的头结点,每个节点的next指针
char e[N];
bool st[N];

int main()
{
    
    
    scanf("%d%d%d", &h1, &h2, &n);

    for (int i = 0; i < n; i ++ )
    {
    
    
        int address, next;
        char data;
        scanf("%d %c %d", &address, &data, &next);
        e[address] = data, ne[address] = next;
    }

    for (int i = h1; ~i; i = ne[i])
        st[i] = true;

    for (int i = h2; ~i; i = ne[i])
        if (st[i])
        {
    
    
            printf("%05d\n", i);
            return 0;
        }

    puts("-1");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121108915
今日推荐