hdu6152Friend-Graph(网络赛暴力+拉姆齐定理)

Friend-Graph

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1384    Accepted Submission(s): 703


Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n3000)

Then there are n-1 rows. The  ith row should contain n-i numbers, in which number  aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
 

Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
 

Sample Input
 
  
1 4 1 1 0 0 0 1
 

Sample Output
 
  
Great Team!
 

Source

选出有超过3个关系好的或者三个以上关系不好的人的团队,输出bad,否则great

拉姆齐定理,n超过6,则一定存在关系超过3,输出bad,n少于2,一定是great,其余暴力就是了

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <iostream>
using namespace std;
#define N 3010
bool rel[N][N];
int n;
int solve()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=i+1;j<=n;j++)
        {
            for(int k=j+1;k<=n;k++)
            {
                int x=rel[i][j]+rel[j][k]+rel[k][i];
                if(x==3||x==0)
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);

    while(t--)
    {
        //memset(num,0,sizeof(num));
        memset(rel,0,sizeof(rel));
        scanf("%d",&n);

        //memset(sum,0,sizeof(sum));
        for(int i=1; i<=n-1; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                int num;
                scanf("%d",&num);
                rel[i][j]=rel[j][i]=num;
            }
        }
        if(n>6)
        {
            cout<<"Bad Team!"<<endl;
            continue;
        }
        if(n<=2)
        {
             printf("Great Team!\n");
             continue;
        }
        int flag=solve();
        if(flag)
            printf("Bad Team!\n");
        else
            printf("Great Team!\n");
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_32792879/article/details/77504563