(binary_search) Can you find it hdu2141

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)

Total Submission(s): 35782    Accepted Submission(s): 8831

Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

Sample Input

3 3 3

1 2 3

1 2 3

1 2 3

3

1

4

10

Sample Output

Case 1:

NO

YES

NO

思路:

此处可以用暴力求解法以及二分查找法(会节省更多时间)。而二分查找是有对应的STL的。此处是可以用binary_search,是在有序数列中确定给定的元素是否存在。

#include <iostream>
#include <algorithm>
using namespace std;
int a[501],b[501],c[501],sum[250010],s[1001];
int main()
{
    int l,n,m,i,j,s1,T=0;
    while(scanf("%d%d%d",&l,&n,&m)!=EOF)
    {
        T++;
        for(i=0;i<l;i++)
            scanf("%d",&a[i]);
        for(i=0;i<n;i++)
            scanf("%d",&b[i]);
        for(i=0;i<m;i++)
            scanf("%d",&c[i]);
        for(i=0;i<l;i++)
        {
            for(j=0;j<n;j++)
                sum[n*i+j]=a[i]+b[j];
        }
        sort(sum,sum+l*n);
        scanf("%d",&s1);
        for(i=0;i<s1;i++)
            scanf("%d",&s[i]);
        printf("Case %d:\n",T);
        for(i=0;i<s1;i++)
        {
            for(j=0;j<m;)
            {
                if(binary_search(sum,sum+l*n,s[i]-c[j]))
                    break;
                j++;
            }
            if(j!=m)
                printf("YES\n");
            else
                printf("NO\n");
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Weixu-Liu/p/9173673.html