问题 : Legal or Not (拓扑排序+有向图)

问题 : Legal or Not

时间限制: 1 Sec  内存限制: 32 MB

http://218.198.32.182/problem.php?cid=1071&pid=6

题目描述

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

输入

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

输出

For each test case, print in one line the judgement of the messy relationship.If it is legal, output "YES", otherwise "NO".

样例输入

4 3
0 1
1 2
2 3
3 3
0 1
1 2
2 0
0 1

样例输出

YES
NO

典型的拓扑排序,一个有向图,看是否能构成一个环,如果能输出no,否则输出yes

代码如下。

# include <stdio.h>
# include <string.h>

int main(void)
{
	int n, m, i, j, x, y, k, c;
	int q[110][110], v[110];
	while (~ scanf("%d %d", &n, &m))
	{
		if (n == 0)
		break;
		memset(q, 0, sizeof(q));
		memset(v, 0, sizeof(v));
		for (i = 0; i < m; i ++)
		{
			scanf("%d %d", &x, &y);
			if (q[x][y] == 0)
			{
				q[x][y] = 1;
				v[y] ++;
			}
		}	
		c = 0;
		for (i = 1; i <= n; i ++)
		{
			k = -1;
			for (j = 0; j < n; j ++)
			{
				if (v[j] == 0)
				{
					k = j;
					break;
				}
			}
			if (k == -1)
				break;
			else
			{
				v[k] --;
				c ++;
				for (j = 0; j < n; j ++)
				{
					if (q[k][j] == 1)
					v[j] --;
				}
			}
		}

		if (c != n)
			printf("NO\n");
		else
			printf("YES\n");
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/liu344439833/article/details/80183930
今日推荐