Firetruck UVa208

/*
208
Firetruck
The Center City fire department collaborates with the transportation department 
to maintain maps ofthe city which reflects the current status of the city streets.
On any given day, several streets are closed for repairs or construction.  
Firefighters need to be able to select routes from the firestations to fires that do not use closed streets.
Central City is divided into non-overlapping fire districts, each containing a single firestation. When
a fire is reported, a central dispatcher alerts the firestation of the district where the fire is located and
gives a list of possible routes from the firestation to the fire. You must write a program that the central
dispatcher can use to generate routes from the district firestations to the fires.
Input
The city has a separate map for each fire district. Streetcorners of each map are identified by positive
integers less than 21, with the firestation always on corner #1. The input file contains several test cases
representing different fires in different districts.
•
The first line of a test case consists of a single integer which is the number of the streetcorner
closest to the fire.
•
The next several lines consist of pairs of positive integers separated by blanks which are the
adjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, then
the street between streetcorners 4 and 7 is open. There are no other streetcorners between 4 and
7 on that section of the street.)
•
The final line of each test case consists of a pair of
0
’s.
Output
For each test case, your output must identify the case by number (‘
CASE 1:
’, ‘
CASE 2:
’, etc). It must
list each route on a separate line, with the streetcorners written in the order in which they appear on
the route. And it must give the total number routes from firestation to the fire.
Include only routes
which do not pass through any streetcorner more than once.
(For obvious reasons, the fire
department doesn’t want its trucks driving around in circles.)
Output from separate cases must appear on separate lines.
Sample Input
6
1 2
1 3
3 4
3 5
4 6
5 6
2 3
2 4
0 0
4
Universidad de Valladolid OJ:
208  –  Firetruck
2/2
2 3
3 4
5 1
1 6
7 8
8 9
2 5
5 7
3 1
1 8
4 6
6 9
0 0
Sample Output
CASE 1:
1   2   3   4   6
1   2   3   5   6
1   2   4   3   5   6
1   2   4   6
1   3   2   4   6
1   3   4   6
1   3   5   6
There are 7 routes from the firestation to streetcorner 6.
CASE 2:
1   3   2   5   7   8   9   6   4
1   3   4
1   5   2   3   4
1   5   7   8   9   6   4
1   6   4
1   6   9   8   7   5   2   3   4
1   8   7   5   2   3   4
1   8   9   6   4
There are 8 routes from the firestation to streetcorner 4.
*/

题目大意:无向图 编号1~n  起始点始终是1,终止点是输入的N   ,  按要求输出1~N所有路径。

用数组集合来模拟邻接矩阵存储数据,同时满足题意按字典序输出,因为set本身的不重复性,可利用这一性质和find()查找已走过的节点  来代替visited[]。

两个dfs 其中vector<string> paths 将数据写进流中,然后转换为string类型压入容器, 使得最后输出数据变得方便。

输出vector<string> 利用puts(p.c_str()) 讲string转换成char* 型  直接输出 要比两重for循环好。

AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<string>
#include<set>
#include<map>
#include<sstream>
#include<queue>
#include<stack>
#include<cmath>
#include<list>
#include<vector>
#include<bitset>
using namespace std;
#define _for(i,a,b) for( int i = (a) ; i < (b) ; i ++ )
const int MAX = 24;
int N, parent[MAX];
set<int> g[MAX];

ostream& operator<<(ostream& os, const vector<int>& s) {
	bool first = true;
	for (const auto  x:s) {
		if (first) 
			first = false;
		else
			os << ' ';
		os << x;
	}
	return os;
}
int find(int q) {
	while (q != parent[q])
		q = parent[q];
	return q;
}
void dfs(int start, int end, vector<int>& path, vector<vector<int> >& paths) {

	path.push_back(start);
	if (start == end) {
		paths.push_back(path);
		return;
	}
	for (auto v : g[start]) {
		if (find(path.begin(), path.end(), v) != path.end())
			continue;
		dfs(v, end, path, paths);
		path.pop_back();
	}
	
}
void dfs(int start, int end, vector<int>& path, vector<string>& paths) {

	path.push_back(start);
	if (start == end) {
		stringstream os;
                //重载后 os已经是写好的流对象
                os << path;
                //str()是stringstream 自身的成员函数  讲流的内容转换成string类型
                paths.push_back(os.str());
		return;
	}
	for (auto v : g[start]) {
		if (find(path.begin(), path.end(), v) != path.end())
			continue;
		dfs(v, end, path, paths);
                //一定要弹出
                path.pop_back();
	}

}
void println( int kase , vector<vector<int> > paths ) {
	printf("CASE %d:\n", kase);
	_for(i, 0, paths.size()) {
		_for(j, 0, paths[i].size()) {
			cout << paths[i][j];
			if (j < paths[i].size() - 1)
				cout << " ";
		}
		cout << endl;
	}
	printf("There are %lu routes from the firestation to streetcorner %d.", paths.size(), N);
}
void println(int kase, vector<string> paths) {
	printf("CASE %d:\n", kase);
	for(auto& p: paths)
		puts(p.c_str());
	printf("There are %lu routes from the firestation to streetcorner %d.", paths.size(), N);
}
int main()
{
	ios::sync_with_stdio(false);
	for (int kase = 1, from, to; cin >> N; kase++) {
		for (int i = 0; i < MAX; i++) {
			g[i].clear();
			parent[i] = i;
		}
		while (true) {
			cin >> from >> to;
			if (from == 0 || to == 0)
				break;
			g[from].insert(to);
			g[to].insert(from);
			int p = find(from);
			int q = find(to);
			if (p != q)
				parent[p] = q;
		}

		vector<string> paths;
	//	vector<vector<int> > paths;
		vector<int> path;
	
		if (find(1) == find(N))
			dfs(1, N, path, paths);
		println(kase,paths);
	}
	return 0;
}




猜你喜欢

转载自blog.csdn.net/a673786103/article/details/79912450