【PAT】A1027. Colors in Mars (20)

Description:
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input
Each input file contains one test case which occupies a line containing the three decimal color values.

Output
For each test case you should output the Mars RGB value in the following format: first output “#, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input

15 43 71


Sample Output

#123456

//NKW 甲级练习题1006
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
char mp[] = {'0','1','2','3','4','5','6','7','8','9','A','B','C'};
const int maxn = 10;
void change(int a){
	int z[maxn], num = 0;
	do{
		z[num++] = a % 13;
		a /= 13;
	} while (a != 0);
	if (num == 1)                //保证左端补零
		printf("0");
	for (int i = num - 1; i >= 0; i--)
		printf("%c", mp[z[i]]);
}
int main(){
	int r, g, b;
	scanf("%d %d %d", &r, &g, &b);
	printf("#");
	change(r);
	change(g);
	change(b);
	printf("\n");
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/80918758