[Python](PAT)1027 Colors in Mars(20 分)

版权声明:首发于 www.amoshuang.com https://blog.csdn.net/qq_35499060/article/details/82086204

用python写PAT甲级,答案都在这

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

题目大意

给定三个十进制整数,将它们转换成十三进制,合并字符串后在首位加上“#”输出。

分析

因为整数的范围是[0-168],所以十三进制下,不会超过两位。

用l表示13进制的数字列表

第一位数是第a // 13个数字

第二位是第a % 13个 数字

合并字符串之后输出

python实现

def change(num):
    l = '0123456789ABC'
    a = int(num)
    first, second = a // 13, a % 13
    return l[first] + l[second]

if __name__ == "__main__":
    line = input().split(" ")
    result = ''
    for x in line:
        result += change(x)
    print('#'+result)

猜你喜欢

转载自blog.csdn.net/qq_35499060/article/details/82086204