【笨方法学PAT】1027 Colors in Mars (20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/83269443

一、题目

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

二、题目大意

给定3个[0,168]范围内的10进制数,将它们转换为13进制数后按顺序输出。 

三、考点

进制转换

四、解题思路

1、10进制转为13进制即可。

五、代码

#include<iostream>
#include<string>
using namespace std;
int main() {
	//read
	int e[3];
	cin >> e[0] >> e[1] >> e[2];

	//solve
	cout << "#";
	for (int i = 0; i < 3; ++i) {
		int a1, a2;
		char b1, b2;
		a1 = e[i] / 13;
		a2 = e[i] % 13;
		if (a1 >= 10)
			b1 = (char)(a1 - 10 + 'A');
		else
			b1 = (char)(a1 + '0');
		if (a2 >= 10)
			b2 = (char)(a2 - 10 + 'A');
		else
			b2 = (char)(a2 + '0');
		cout << b1 << b2;
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/83269443