poj 2393 Yogurt factory

Description
The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky’s factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt’s warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky’s demand for that week.

Input
* Line 1: Two space-separated integers, N and S.

  • Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output
* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

#include<cstdio>
int a[11000],b[11000];
int main(){
    int n,s,i;
    while(scanf("%d%d",&n,&s)!=EOF){
        for(i=1;i<=n;i++)
            scanf("%d%d",&a[i],&b[i]);
        for(i=2;i<=n;i++)
            if(a[i]>a[i-1]+s)
                a[i]=a[i-1]+s;
       long long t=0;
        for(i=1;i<=n;i++)
            t+=a[i]*b[i];
        printf("%lld\n",t);
    }return 0;
}

猜你喜欢

转载自blog.csdn.net/u012678352/article/details/80951150