poj-2393-Yogurt factory

Yogurt factory
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13761   Accepted: 6904

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

Input

* Line 1: Two space-separated integers, N and S. 

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

Hint

OUTPUT DETAILS: 
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units. 
题目大意:一个工厂生产酸奶,酸奶可以放在仓库里不会过期,然后告诉你接下来N周的酸奶生产价格,以及放在仓库里的租金,下面是N周的酸奶生产价格以及用户需求量,求如何生产才能使付出最少

思路:贪心,将本周的生产价格和下周的生产价格和租金加起来相比,取最小,然后乘上单位量就是最小租金

代码:

#include<map>
#include<stack>
#include<cmath>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 11000
#define ll long long
int c[maxn],y[maxn];
int main()
{
   int n,s;
   while(scanf("%d%d",&n,&s)!=EOF)
   {
       int i,j,k;
       ll ans=0;
       for(i=0;i<n;i++)
       {
           scanf("%d%d",&c[i],&y[i]);
           if(i>=1)
           {
               c[i]=min(c[i],c[i-1]+s);
           }
       }
       for(i=0;i<n;i++)
       {
           ans+=c[i]*y[i];
       }
       printf("%lld\n",ans);
   }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lee371042/article/details/81026842