HDU1162 Eddy's picture【Kruskal算法+并查集】

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11842    Accepted Submission(s): 5923


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.  

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.  
 

Sample Input
 
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
 
  
3.41

问题链接HDU1162 Eddy's picture

问题描述:(略)

问题分析

  这是一个最小生成树的为问题,解决的算法有Kruskal(克鲁斯卡尔)算法和Prim(普里姆) 算法。

程序说明

  本程序使用Kruskal算法实现。有关最小生成树的问题,使用克鲁斯卡尔算法更具有优势,只需要对所有的边进行排序后处理一遍即可。程序中使用了并查集,用来判定加入一条边后会不会产生循环。程序中,图采用边列表的方式存储,排序一下就好了。

  这个题给的是坐标,需要计算距离。


AC的C++语言程序如下:

/* HDU1162 Eddy's picture */

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <math.h>

using namespace std;

const int N = 100;

int f[N * (N - 1) + 1];

void UFInit(int n)
{
    for(int i = 1; i <=n; i++)
        f[i] = i;
}

int Find(int a) {
    return a == f[a] ? a : f[a] = Find(f[a]);
}

bool Union(int a, int b)
{
    a = Find(a);
    b = Find(b);
    if (a != b) {
        f[a] = b;
        return true;
    } else
        return false;
}

struct Point {
    double x, y;
} p[N];

struct Edge {
    int u, v;
    double w;
} edges[N * (N - 1)];

bool cmp(Edge& a, Edge& b)
{
    return a.w < b.w;
}

int main()
{
    int n;
    while(~scanf("%d", &n)) {
        UFInit(N);

        for(int i = 0; i < n; i++)
            scanf("%lf%lf", &p[i].x, &p[i].y);

        int cnt = 0;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++)
                if(i < j) {
                    edges[cnt].u = i + 1;
                    edges[cnt].v = j + 1;
                    edges[cnt++].w = sqrt((p[i].x - p[j].x) * (p[i].x - p[j].x) + (p[i].y - p[j].y) * (p[i].y - p[j].y));
                }

         // Kruscal算法
        double ans = 0;
        sort(edges, edges + cnt, cmp);
        for(int i = 0; i < cnt; i++) {
            if(Union(edges[i].u, edges[i].v))
                ans += edges[i].w;
        }

        printf("%.2f\n", ans);
    }

    return 0;
}







猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80887949