【PAT 甲级】1025 PAT Ranking (25)(结构体排序)

题目链接

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题意:有N组数据,将N组数据合并后,输出对应的排序结果。格式:registration_number   final_rank   location_number   local_rank。

思路:结构体排序  注意控制注册号的位数为13位。

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <cstring>
#include <map>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int N = 1e6+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;
const int T=3;

struct Node
{
    ll id,loc,score,locRank,rank;
    bool operator < (const Node& m)const{
        if(score!=m.score) return score>m.score;
        return id<m.id;
    }
}a[N];
int main(){
    int T;
    cin>>T;
    int cnt=0,n;
    for(int loc=1;loc<=T;loc++){
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>a[cnt+i].id>>a[cnt+i].score;
            a[cnt+i].loc=loc;
        }
        sort(a+cnt,a+cnt+n);
        for(int i=0;i<n;i++){
            if(!i||a[cnt+i].score!=a[cnt+i-1].score){
                a[cnt+i].locRank=i+1;
            }else {
                a[cnt+i].locRank=a[cnt+i-1].locRank;
            }
        }
        cnt+=n;
    }
    sort(a,a+cnt);
    for(int i=0;i<cnt;i++){
        if(!i||a[i].score!=a[i-1].score){
            a[i].rank=i+1;
        }else {
            a[i].rank=a[i-1].rank;
        }
    }
    cout<<cnt<<endl;
    for(int i=0;i<cnt;i++){
            printf("%013lld %lld %lld %lld\n",a[i].id,a[i].rank,a[i].loc,a[i].locRank);
//        cout<<a[i].id<<" "<<a[i].rank<<" "<<a[i].loc<<" "<<a[i].locRank<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81006861