PAT甲级 1025. PAT Ranking (25) 排序

1025. PAT Ranking (25)
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目大意:有n个考场,每个考场有若干数量的学生,给出每个考场中考生的编号和分数,要求算排名,输出所有考生的编号、排名、考场号、考场内排名
分析:先按照考场内排名 然后赋值给总数组fin,然后总排名,最后输出。注意相同的分数情况下按照学号的从小到大排列,但是他们的排名应该是一样的数字~~~

#include<iostream>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;

struct stu{
	string registration_number;
	int location_number,score,local_rank,final_rank;
};

int cmp(stu a,stu b){
	//if(a.score == b.score){//先比较分数,再进行考生号比较 
	//	return a.registration_number < b.registration_number;
	//}else
	//	return a.score > b.score;
	return a.score == b.score ? a.registration_number < b.registration_number : a.score > b.score;
} 

int main(){
	int n,k;
	cin>>n;

	vector<stu> vec[300];
	for(int i=1;i<=n;i++){
		cin>>k;
		for(int j=0;j<k;j++){
			string str;
			int score;
			cin>>str>>score;
			vec[i].push_back(stu{str,i,score,-1,-1});
		}
		sort(vec[i].begin(),vec[i].end(),cmp);//先排序并进行当前考场排名 
		int rank = 1,curr_score = vec[i][0].score;
		vec[i][0].local_rank = 1;
		for(int j=1;j<k;j++){
			if(vec[i][j].score != curr_score){
				curr_score = vec[i][j].score;
				vec[i][j].local_rank = j+1;
				rank = j+1;
			}	
			else{
				vec[i][j].local_rank = rank;
			}
		}
	}
	
	vector<stu> res;//合并所有考生 
	for(int i=1;i<=n;i++){//合并所有考生 
		for(int j = 0;j<vec[i].size();j++)
			res.push_back(vec[i][j]);
	}
	
	sort(res.begin(),res.end(),cmp);//将所有考生进行一次总体排名 
	int rank = 1,curr_score = res[0].score;
	res[0].final_rank = 1;
	for(int j=0;j<res.size();j++){
		if(res[j].score != curr_score){
			curr_score = res[j].score;
			res[j].final_rank = j+1;
			rank = j+1;
		}	
		else{
			res[j].final_rank = rank;
		}
	}
	
	cout<<res.size()<<endl;
	for(int j=0;j<res.size();j++){
		cout<<res[j].registration_number<<" "<<res[j].final_rank<<" "<<res[j].location_number<<" "<<res[j].local_rank<<endl;
	}
		
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/81628779
今日推荐