比较x^y和y^x的大小

给你两个数x, y, 比较 x^y 和 y ^ x 的大小

Input

两个数 x, y, ( 1 <= x , y <= 109 )

Output

如果 x ^ y < y ^ x , 输出 “<”

如果 x ^ y > y ^ x , 输出 “>”

如果 x ^ y = y ^ x , 输出 “=”

Sample Input

Input
5 8
Output
>
Input
10 3
Output
<
Input
6 6
Output
=

Sample Output

Hint

第一个例子 5 ^ 8 =  390625, 8 ^ 5 = 32768. 输出 '>'.

第二个例子 10 ^ 3 = 1000 < 3 ^10 = 59049.

第三个例子 6 ^ 6 = 46656 = 6 ^ 6.

思路:为了使数据量变小,可以采用两边取对数来判断大小,C++使用log()函数,默认底为e

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cstring>
#include <cmath>
using namespace std;

int main()
{
    long long int x,y;
    scanf("%lld%lld",&x,&y);
    if(x==y)
        printf("=\n");
    else
    {
        if((double)y*log(x)>(double)x*log(y))
            printf(">\n");
        else if((double)y*log(x)<(double)x*log(y))
            printf("<\n");
        else
            printf("=\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38984851/article/details/81048394
今日推荐