POJ 1298 The Hardest Problem Ever 简单凯撒密码问题 | 字符串+输入输出+遍历

The Hardest Problem Ever

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10638    Accepted Submission(s): 4748


 

Problem Description

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 

Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 

A single data set has 3 components: 

Start line - A single line, "START" 

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 

End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT".

Output

For each data set, there will be exactly one line of output. This is the original message by Caesar.

Sample Input

 

START NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX END START N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ END START IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ END ENDOFINPUT

Sample Output

 

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

Source

South Central USA 2002


题目大意是 字符串输入以 START字符开始,以END表示结束,然后ENDOFINPUT总输入结束

整体考察 字符串基础知识,输入输入,因为字符总数不多,所以可以进行下遍历。

算是个水题。

用c语言就可以轻松解决

#include <stdio.h>

int main() {
	char a[20],b[1000],c[20];
	while(1){
		gets(a); 

		if(a[0]=='E') {
			break;
		}else 
		if(a[0]=='S'){
			gets(b); 
			int i=0;
			for(;b[i];i++){
				if(b[i]>=(int)'A'&&b[i]<=(int)'E'){
					printf("%c",b[i]+21);
				}else if(b[i]>=(int)'F'&&b[i]<=(int)'Z'){
					printf("%c",b[i]+21-26);
				}else{
					printf("%c",b[i]);
				}
			}
		}
		gets(c); 
		printf("\n");
	} 
	 
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41523096/article/details/81127077