K-th Number --主席树求区间第k小

题目链接 http://poj.org/problem?id=2104

K-th Number

Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 66823   Accepted: 23587
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

主席树模板题

两篇主席树的学习资料

https://blog.csdn.net/creatorx/article/details/75446472

https://blog.csdn.net/mdnd1234/article/details/69371626 ---这篇有分析的比较有理有据

尤其是这段话 让我恍然大悟

#include<algorithm>
#include<cstdio>
#include<cstring>

using namespace std;

const int maxn = 100011;

struct node
{
    int L,R;
    int sum;
    node()
    {
        this -> sum = 0;
    }
}t[maxn * 20];

struct value
{
    int x,id;
}Value[maxn];

int cnt;
int root[maxn],ran[maxn];

int cmp(value a,value b)
{
    return a.x < b.x;
}

void init()
{
    cnt = 1;
    root[0] = 0;
    t[0].L = t[0].R = t[0].sum = 0;
}

void update(int num,int &rt,int l,int r)
{
    t[cnt ++] = t[rt];
    rt = cnt - 1;

    t[rt].sum += 1;
    if(l == r)
        return ;
    int mid = (l + r) >> 1;

    if(num <= mid)
        update(num,t[rt].L,l,mid);
    else
        update(num,t[rt].R,mid + 1,r);
}

int query(int i,int j,int k,int l,int r)
{
    ///printf("%d %d %d %d||\n",i,j,l,r);

    if(l == r)
        return l;
    int d = t[t[j].L].sum - t[t[i].L].sum;

    int mid = (l + r)>>1;

    if(k <= d)
        return query(t[i].L,t[j].L,k,l,mid);
    else
        return query(t[i].R,t[j].R,k - d ,mid + 1,r);
}

int main()
{
    int n,m;
    scanf("%d %d",&n,&m);

    init();
    for(int i = 1;i <= n;i ++)
    {
        scanf("%d",&Value[i].x);

        Value[i].id = i;
    }

    sort(Value+1,Value + 1 + n,cmp);

    for(int i = 1;i <= n;i ++)
    {
        ran[ Value[i].id ] = i;
    }

    for(int i = 1;i <= n;i ++)
    {
        root[i] = root[i - 1];

        update(ran[i],root[i],1,n);
    }

    int left,right,k;
    for(int i = 1;i <= m;i ++)
    {
        scanf("%d %d %d",&left,&right,&k);

        printf("%d\n",Value[query(root[left - 1],root[right],k,1,n)].x);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ii0789789789/article/details/81101318