ACM——hdu1003(dp经典问题之求最大连续子序列和)

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

解题思路

  1. 明确最大连续子序列和的意义:从中取两个数,两个数之间的所有数相加和最大。这个和一定比它的自序列中任何一个数要大。
  2. 求最大字段和,sum[i]表示以i结尾(字段和中包含 i )在 a[1..i] 上的最大子字段和,状态转移方程表示为sum[i]=(sum[i-1]+a[i]>a[i])?sum[i-1]+a[i]:a[i];
  3. 所有子字段和中最大字段和为max = {sum[i],1<=i<=n} ;

Submission

#include <stdio.h>
int main() {
    int m,n,x,num,i;
    int a[100001]={0};
    int sum[100001]={0};
    int max,start,end,start1,end1;
    scanf("%d",&n);
    for(m=1;m<=n;m++) 
    {
        scanf("%d",&num);
        max=-1001;
        start=1;
        end=1;
        start1=1;
        end1=1;
        for(i=1;i<=num;i++){
            scanf("%d",&a[i]);
            if(sum[i-1]+a[i]>=a[i]) {
                sum[i]=sum[i-1]+a[i];
                end=i;
            }
            else{
                sum[i]=a[i];
                start=end=i;
            }
            if(max<sum[i]){
                max=sum[i];
                start1=start;
                end1=end;
            }
       }
    printf("Case %d:\n%d %d %d",m,max,start1,end1);
    if(m!=n){
        printf("\n\n"); 
    }
    else{
        printf("\n");
    }
}
    return 0;

}

猜你喜欢

转载自blog.csdn.net/Marilynmontu/article/details/81164850