Candies POJ - 3159 (差分约束+SPFA)

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

题意:

一共给n个小朋友分糖果,每个同学都喜欢与其他人比较,A认为B比他多的数量少于C,他就

开心,求第1个同学和第n个同学最多相差几块糖果

思路:设dis[x] 为第x个同学比第1个同学多的糖果数量

将题目建模抽象为,求dis[ n ]

dis[ b ]  -  dis [ a ]  <= c

则dis [ b ] <= dis[ a ] +c  建从a到b的权值为c的边

求最短路

用queue会超时,用数组表示队列

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 30005;
const int M = 150005;
struct node{
	int v,w;
	int next;
}edge[M];
int id,head[N];
int dis[N],vis[N];
int Q[N],top;
int n,m;
void init(){
	id=0;
	memset(head,-1,sizeof(head));
}
void add(int u,int v,int w){
	edge[id].v=v;
	edge[id].w=w;
	edge[id].next=head[u];
	head[u]=id++;
}
void SPFA(){
	top=0;
	memset(dis,Inf,sizeof(dis));
	memset(vis,0,sizeof(vis));
	dis[1]=0;
	Q[top++]=1;
	vis[1]=1;
	while(top){
		int u=Q[--top];
		vis[u]=0;
		for(int i=head[u];i!=-1;i=edge[i].next){
			int v=edge[i].v;
			int w=edge[i].w;
			if(dis[v]>dis[u]+w){
				dis[v]=dis[u]+w;
				if(!vis[v]){
					vis[v]=1;
					Q[top++]=v;
				}
			}
		}
	}
	printf("%d\n",dis[n]);
}
int main(){
	init();
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;i++){
		int u,v,w;
		scanf("%d%d%d",&u,&v,&w);
		add(u,v,w);
	}
	SPFA();
	return 0;
}

猜你喜欢

转载自blog.csdn.net/islittlehappy/article/details/81157841