Safecracker

=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below." 

Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Output

LKEBA
YOXUZ
GHOST
no solution

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

题解:这道题直接暴力就行了,毕竟最多十二个字母;

代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;

bool cmp(int x,int y)
{
    return x>y;
}

int main()
{
    int a;
    char s[13];
    while(cin>>a>>s )
    {
        if(a==0 && s[0]=='E' && s[1]=='N' && s[2]=='D') break;
        int len=strlen(s);
        int b[13];
        memset(b,0,sizeof(b));
        for(int i=0;i<len;i++)
        {
            b[i]=s[i]-'A'+1;
        }//将字符转化为数字;
        sort(b,b+len,cmp);//将转换得到的数字排序;
        int v,w,x,y,z,f;
        bool c[12];//用来判断五个数是否都不同;
        f=0;
        for(v=0;v<len;v++)
        {
            for(w=0;w<len;w++)
            {
                for(x=0;x<len;x++)
                {
                    for(y=0;y<len;y++)
                    {
                        for(z=0;z<len;z++)
                        {
                            memset(c,0,sizeof(c));
                            c[v]=1;
                            c[w]=1;
                            c[x]=1;
                            c[y]=1;
                            c[z]=1;
                            int sum=0;
                            for(int i=0;i<12;i++)
                                sum+=c[i];
                            if(sum<5) continue;
                            else if(b[v]-b[w]*b[w]+b[x]*b[x]*b[x]-b[y]*b[y]*b[y]*b[y]+b[z]*b[z]*b[z]*b[z]*b[z]==a)
                            {
                                f=1;
                                break;
                            }
                        }
                        if(f) break;
                    }
                    if(f) break;
                }
                if(f) break;
            }
            if(f) break;
        }
        if(f) printf("%c%c%c%c%c\n",b[v]-1+'A',b[w]-1+'A',b[x]-1+'A',b[y]-1+'A',b[z]-1+'A');
        else cout<<"no solution"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/h326301035/article/details/81220146