Safecracker(暴力)

Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5240    Accepted Submission(s): 2622


Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST ===
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
 

Sample Input
 
  
1 ABCDEFGHIJKL 11700519 ZAYEXIWOVU 3072997 SOUGHT 1234567 THEQUICKFROG 0 END
 

Sample Output
 
  
LKEBA YOXUZ GHOST no solution
 

Source
 

Recommend
JGShining
 

Statistic | Submit | Discuss | Note


这题估计是数据弱了。。。五重循环不超时。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

char s[15];
bool vis[15], tag;
int t, len;

int Cal(int y, int w, int v, int x, int z)
{
    v -= 64, w -= 64, x -= 64, y -= 64, z -= 64;
    return (v - w*w + x*x*x - y*y*y*y + z*z*z*z*z);
}

int main()
{
    while(scanf("%d %s", &t, s))
    {
        len = strlen(s);
        if(t == 0 && !strcmp(s,"END")) break;
        tag = true;
        //将可选序列按升序排列
        for(int i = 1; i < len && tag; i++)
        {
            for(int j = 0, tag = false; j < len - i; j++)
            {
                if(s[j] < s[j + 1])
                {
                    swap(s[j], s[j + 1]);
                    tag = true;
                }
            }
        }
        for(int i = 0; i < len; i++) vis[i] = false;
        //若target在值域之外,no solution
        if(Cal(s[0], s[1], s[len - 3], s[len - 2], s[len - 1]) > t || Cal(s[len - 1], s[len - 2], s[2], s[1], s[0]) < t)
            puts("no solution");
        else
        {
            int a, b, c, d, e;
            tag = false;
            for(a = 0; a < len; a++)
            {
                vis[a] = true;
                for(b = 0; b < len; b++)
                {
                    if(!vis[b])
                    {
                        vis[b] = true;
                        for(c = 0; c < len; c++)
                        {
                            if(!vis[c])
                            {
                                vis[c] = true;
                                for(d = 0; d < len; d++)
                                {
                                    if(!vis[d])
                                    {
                                        vis[d] = true;
                                        for(e = 0; e < len; e++)
                                            if(!vis[e] && Cal(s[d], s[b], s[a], s[c], s[e]) == t)
                                            {
                                                tag = true;
                                                goto end;
                                            }
                                        vis[d] = false;
                                    }
                                }
                                vis[c] = false;
                            }
                        }
                        vis[b] = false;
                    }
                }
                vis[a] = false;
            }
            end:
            if(!tag) puts("no solution");
            else printf("%c%c%c%c%c\n", s[a], s[b], s[c], s[d], s[e]);
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/cs_zlg/article/details/8575024