E - Robot Motion


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

题目大意

   就是根据当前坐标的方向进行移动,若能出去,则输出步数,否则,陷入循环,输出从哪开始循环的步数,并输出循环几步

思路

    一开始想的是bfs,自然就会想到队列,不过等到写代码时,发现只是一个循环,只需要用一个二维数组,记录第一次到达该坐标的步数即可,以便输出。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
#include <iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
#include<string>
using namespace std;

const int MAXN=12;
char s[MAXN][MAXN];
int vis[MAXN][MAXN];
int fx[MAXN][MAXN];  // 记录步数
int n,m,l;
struct node
{
    int x,y;
    int step;
};
void BFS(int x,int y)
{
    node e1,e2;
    e1.x=x,e1.y=y,e1.step=0;
    vis[e1.x][e1.y]=0;
    fx[e1.x][e1.y]=0;
    bool f;
    int res,ans;
    while(1){      //判断方向
        if(s[e1.x][e1.y]=='N')
            e1.x=e1.x-1;
        else if(s[e1.x][e1.y]=='E')
            e1.y=e1.y+1;
        else if(s[e1.x][e1.y]=='W')
            e1.y=e1.y-1;
        else if(s[e1.x][e1.y]=='S')
            e1.x=e1.x+1;
        e1.step+=1;
        if(e1.x<0||e1.x>=n||e1.y<0||e1.y>=m){    // 说明已经出去
            f=true;break;
        }
        else if(vis[e1.x][e1.y]==0){   // 第二次到达,说明陷入循环
            res=fx[e1.x][e1.y];
            ans=e1.step;
            f=false;break;
        }
        fx[e1.x][e1.y]=e1.step;
        vis[e1.x][e1.y]=0;

    }
    if(f)printf("%d step(s) to exit\n",e1.step);
    else printf("%d step(s) before a loop of %d step(s)\n",res,ans-res);
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&l)==3){
        if(n==0&&m==0&&l==0)break;
        for(int i=0;i<n;i++)
            scanf("%s",s[i]);
        memset(vis,1,sizeof(vis));
        BFS(0,l-1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hnlg311709000526/article/details/81348306