POJ1573-Robot Motion

版权声明:转载请注明出处 https://blog.csdn.net/doubleguy/article/details/82052891

 

Robot Motion


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

给你一些指令,问你机器人能不能走出这个地图,能就输出步数。不能走出去就一定有环,输出进入环之前走了多少步和走遍环需要多少步。

bfs+模拟实现。

AC代码:

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn = 35;
int l,r,c;
char str[maxn][maxn];
int vis[maxn][maxn];
int stepp[maxn][maxn];
int to[4][2]={-1,0,1,0,0,-1,0,1};
struct node
{
    int x;
    int y;
    int step;
};
void bfs(int stx,int sty)
{
    node now,next;
    int ans=0;
    int flag=0;
    int circle=0;
    memset(vis,0,sizeof(vis));
    memset(stepp,0,sizeof(stepp));
    queue<node>q;
    now.x=stx;
    now.y=sty;
    now.step=0;
    q.push(now);
    vis[stx][sty]=1;
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(str[now.x][now.y]=='W')
        {
            next.x=now.x+to[2][0];
            next.y=now.y+to[2][1];
        }
        if(str[now.x][now.y]=='E')
        {
            next.x=now.x+to[3][0];
            next.y=now.y+to[3][1];
        }
        if(str[now.x][now.y]=='N')
        {
            next.x=now.x+to[0][0];
            next.y=now.y+to[0][1];
        }
        if(str[now.x][now.y]=='S')
        {
            next.x=now.x+to[1][0];
            next.y=now.y+to[1][1];
        }
        next.step=now.step;
        if(next.x>=l||next.y>=r||next.x<0||next.y<0)
            flag=1;
        if(flag)
        {
            ans=next.step+1;
            break;
        }
        if(!vis[next.x][next.y])
        {
            vis[next.x][next.y]=1;
            next.step++;
            stepp[next.x][next.y]=next.step;
            q.push(next);
        }
        else
        {
            circle=++next.step-stepp[next.x][next.y];
            break;
        }
    }
    if(flag)
        printf("%d step(s) to exit\n",ans);
    else
        printf("%d step(s) before a loop of %d step(s)\n",stepp[next.x][next.y],circle);
}

int main()
{
    int stx,sty,stk;
    int edx,edy,edk;
    while(scanf("%d%d%d",&l,&r,&c)&&(l||r||c))
    {
        for(int i=0;i<l;i++)
            scanf("%s",str[i]);
        bfs(0,c-1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/doubleguy/article/details/82052891